Excel 2016 Staff Class
Names and references of cells

Relative reference Ex: =A1*B1

When dragging a formula down a column, the references will
update automatically update the reference. Ex: =a2*B2, =A3*B3
Absolute reference Ex: =A1*S$Fs1 (tip: use F4 to toggle between reference type)
In this case,when dragging the formula down a column, only the
first operand will change. Ex: = A2*$FS$1, =A3*S$SFS1

Mixed reference Ex:=A1*$F1 or =A1*FS1

When dragging the first formula down or across, the part without a
$ sign will change

Named cell / range Formulas > Defined Names > Define Name Variable can be
referenced by its name. Name Manager tracks this info.

Structured Reference | Fields in a Table can be used by name, preceded by an @ sign.

Sheets in a workbook | Rename a sheet by <right click> on tab name. References to a
field from Sheet 1 will look like Sheet_1! followed by cell reference.
Fields from other Not covered in this class. It is possible for one or more workbooks to
workbooks refer to fields from another workbook. All workbooks must be open
to resolve the data.

e =D3+E3

Click and Drag - Autofill e : s - :
To apply a formula all the way down (or across) the rows (or columns) N —

of data, double click the handle in the bottom right corner of the is Doub]e:ic ick here
formula. 2

Useful shortcuts:

<Cntl Enter> accept value and keep cell active

<Cntl .> (Control + period) move active cell fo corners of range. Useful for exploring
the size of the data.

<Cntl ~> (Control +~) or Toggles displaying formulas or the value of the field

Formulas > Formula
Auditing > Show Formulas

<Cntl Shift Enter> To commit a Trim function.
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How to resize columns / rows
- Method 1

Double click the column boundary (the vertical line separating
the column headers) or on the triangle below the Name Box
and then the column width to resize all column sizes.

How to resize columns / rows
- Method 2

Click on Column leftter.
Home > Cells > Format ¥> AutoFit Column Width

F4

Make a reference absolute by selecting the address an
pressing F4.

<Cntl Home>

to jump to the first row and column of the data

<Cntl End>

to jump to the last row and column of the data

Double click on the lower
right bottom fill handle

to apply the formula all the way down.

Arrays vs Tables

Both Arrays and Tables can be used in VLOOKUP and INDEX MATCH, but using a Table has
many advantages over using an Array. As far as | can tell, there are no disadvantages to

using a Table.

Arrays and Tables are similar in that they have a unique “key” in the left most column, and the
left-most column is referred to as “1"”, no matter where it falls in the worksheet.

In Excel, a Table is a specific construct; it has its own formatting style (the zebra rows), it
dynamically changes size if new data is added to it, and even has an additional way of
referencing its data — structured reference.

Array

1 2 3

CC |Cookie Name vegan
1| 10 Thin Mints Vegan
2| 11 Samoas Regular
3| 12 Tagalongs Regular
4] 13 Trefoils Regular
5| 14 Do-si-dos Regular
6| 15 Savannah Smiles  Regular
7| 16 Toffee-tastic Regular
8| 17| Girl Scout S'mores Vegan
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Table
1 2 3
1 10 Thin Mints Vegan
2 11 Samoas Regular
3 12 Tagalongs Regular
4 13 Trefoils Regular
5 14 Do-si-dos Regular
6 15 Savannah Smiles Regular
7 16 Toffee-tastic Regular
8 17 Girl Scout S'mores Vegan

The little blue corner means End-of-Table.
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My favorite links

Bit.ly/mhnVLookup How to use the Excel VLOOKUP, by Exceljet

Bit.ly/IndexFunction How to use the Excel INDEX function, by Exceljet

Bit.ly/MatchFunction How to use the Excel Match function, by Exceljet

Bit.ly/MoveSheet Move or copy worksheets or worksheet data by
support.office.com (MS)

Bit.ly/StructRef Create and use Structured References in a Table.

Bit.ly/RelateTable A good primer for how relational tables work, covering primary

keys, foreign keys, redundant data, and links for further study.
Required to create a good Data Model

Bit.ly/CreateDataModel Create a Data Model in Excel by MS
Good overview to join multiple Tables in a PivotTables and
PivotCharts

Bit.ly/CreatePT How to create a Pivot Table, by MS

Bit.ly/GetPTSubtotal Access subtotals in PivotTables for use in other reports — works

even if / when the PivotTable is updated. By Exeljet.
http://bit.ly/TreeMapGraph | How to make Tree Graphs, Sunburst Graphs,

Pivot Tables
The frickiest thing about Pivot Tables is asking the right question to “see” your data. Do you
want to see the sales of cookies broken down by cookie type? Or to see sales by Scout?

Requirements:

e Data must be a Table or an Array. This means all of the cells in a column are filled in
(see below). If new rows are added in a Table, the Pivot Table will “see” them after
Refreshing the Cache (Alt F5)

e No empty rows. If the source of a Pivot Table has an empty row, “Summed” fields
become “Count” or other unexpected problems surface.

Test Test Qty Test Total Test

Test Scout - Cookie [~ Sold |- Amount -~ Test Qty Test Total
Alondra Huerta 11 ) $30.00 Test Scout Cookie Sold Amount

Alondra Huerta 12 3 $15.00 Alondra Huerta 11 é $30.00
Cesare Vale 16 2 $10.00 12 3 $15.00
Cesare Vale 16 2 $10.00 Cesare Valle 16 2 $10.00
Mary Porterfield [ 3 ) $25.00 16 2 $10.00
Mary Porterfield 15 2 $9.50 Mary Porterficld 13 5 $25.00
Mary Porterfield 10 3 $14.25 15 2 3950
Total $113.75, 10 3 $14.25

Good example Bad example — the Scout names are not on
every row. SKOKIE
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Click on the Sales Data worksheet tab, this holds the “Many Troops™ Table.
Create a Pivot Table by dragging the Troop label in the Rows area, Cookie in the column, and
the sum of Qty label in the Values field.

Right click on a field

A B lc|p|E|F|lG[H|I] J K Py ) . -
1 PivotTable Fields to get this pop up.
2| Choose fields to add to i i
3 [Sum of iy _|Column Labeis| - e « -/ Click on Value Field
4 [Row Labels - 10 11 12 13 14 15 16 17 Grand Total Settings.
Search jo, .
5 34 3 6 3 5 2 4 23 !"E‘
6 35 16 324153010 219 119 oy SR B
7 |44 1 4 5 3 1 14 7| Canlia - Format Cells...
8 446 16 324153010 219 119
9 4554 25 14 20 20 11 15 14 19 142 Drag fields between areas below: 1 Number Format...
10 Grand Total 60 26 72 55 75 46 25 58 47 [ - ([& Refresh
11
]2* Cookie hd I Sort '
]3_ x Remoye "Sum of Qty"
]4: = ROWS 2 VALUES Summarize Values By »
}2— Troop v || SumofQty ~ Show Values As »
17 | *= Show Details
v EEEEH sheet? EEIEDEEN SmallDi.. @ @ 4 3 Defer Layout Upd.. g Value Field Settings..

Figure 1 This Excel screen may be slightly different than yours.

Source Name:  Qty

Custom Name: |Sum of Qfy

summarize Values By Show Values As

Summarize value field by

Value Field Settings

Choose the type of calculation that you want to use to summarize
data from the selected field

? Il

MNumber Format

Cancel

Value Field

Source Name:

aty

Lustom Mame:  Sum of Oty

Summarize Values By ||
Show values as

Mo Calculation

Base field:

Base item:

Settings

Scout
Customer
Coakie

Number Format

.

Cancel
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PivotTable Options..
E | Hide Field List

PivotTable Name: | PivotTable7]

Printing
Layout & Format

Layout

|:| Merge and center cells with labels

When in compact form indent row labels: 1 =

Display fields in report filter

Report filter fields per column: | 0 =

Format
D For error values show:

For empty cells show:

Autofit column widths on update
Preserve cell formatting on update

2 I

PivotTable Options

Data Alt Text

Totals & Filters Display
character(s)

area: Down, Then Over hd

.

Cancel
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Things to try:
Sort

Click the down arrow by Row Labels. Sort the data by Troop number. Or by Grand Total to
see the top selling froop first.

Count, Sum, Average
The default in the Values field is to SUM the data, but click on the drop down arrow and
change it to COUNT, or Average.

Drag another instance of Qty to the Values field and change it to COUNT.

% as a percentage

Keep Troop in Row, two instances of Money in Values field, nothing in the column field.
Right click one of the Money fields,

Select “Show Values As” to “% of Grand Total”.

Group @ P.ivo’r Table manually o . Grouping  ?
Create a Pivot table where Cookies isin the Row, and Money is
in the Values field

Auto
Starting at: 1()|

<Right Click> on the Cookie number, select Group, change Mgndingat |17

fields to look like the example on the right. & :

Or

Click on the Pivot Table Tools > Analyze tab.

Select one or more Cookie numbers (hold down the Cntl
key to select non-contiguous rows).

Click on Group > Group Selection.

Row Labels - |5um of money2 Sum of money
- Group2

V] 296 14.38%
1 129.25 6.28%
354.25 1721%

Select another (or the remainder) cookies for other
groupings.

1
2
3
4
5
é 1
7
8
¥
10
1

2

13 27125 13.16%
5 228.75 1%
1 16 125.25 6.08%

12 | =Group3

13 14 368.5 17.90%

4|17 2855 1387%

Now the Groups can be sorted. A
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Power Pivot using data from

B Create Relationship
multiple Tables
Pick the tables and columns you want to use for this relationship
Create arelationship between | e Column (Foreion:
ManyTroops v | Cookie v
TWO TO bl es , Related Table: Related Column (Primary):
TabCookie v v

1. Click on ALL in upper right corner
under the Pivot Table Fields.

2. Select the fields you want from Manage Relationships. Cancel
two different tables — TabCookie
and ManyTroops.

3. Click Create Relationship (see upper e

'@ Insert  Pagelayout Formulas Data  Review  View  Analyze  Design

Creating relationships between tables is necessary to show related data from different tables on the same report.

right picture), click OK. : % T oo :
4. Now select “Cookie Name" from A 3 c bk RN _
PivotTable Fields ™ *
. . . 3 [Rowlabels - |sumofQly
TabCookie, and display that instead of O — 28 scrve ()
the Cookie number. ‘; ?353&”@23"”&‘ ‘ rcs:gurfnemmdum e
8 Thin Mints 3 Search 0
? Toffe.ertc:sﬂc 2 ey Teoces .
Why? :? _HTre!ouIs ”2
12 Do-si-dos 30 T e -
L CH Scout Smores 19 Drag fields between areas below:
14 Samoas 4
Changing data in one master table will quickly |2 ?g;gg:‘;’;“”e‘ » YAUTERS I columns
propagate through the rest of the PivotTables. 8 Toffee-tasic 5
;; -uTrem"S 112 = ROWS T VALUES
21 Do-si-dos 4 Traop - ||| Sumof Qty =
Ex: a customer changes their phone number, 2] CHscout Smores i Cooners ~
and we update it in a CustomerTable. M R shees N TR - ¢ - 7| O ot pa
1 Ready B B o - 1 + 100%
Now every order for that customer will

immediately contain the correct information.

Pivot Table Chart

In the Analyze tab of the PivotTable Tools, click on PivotChart. Select one of the
recommended charts — fry the Clustered Bars.

Charts

The Library teaches a Charts class where you can learn all about how to Drawing Tools
make and update Charts. For a quick refresher: Formt
http://www.gcflearnfree.org/excel2016/charts/1/ M @HInz (=i

o~ ¥ View ¥ View

Print Prin

[F} Sheet Options e
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Print preview stider
In the boffom right comer of Excel, you'll see the zoom slider g - G + e
bar. Drag the vertical bar to the left or right to zoom out or

zoom in. Page Break Preview

There are three icons to the left of the zoom; these Workbook Views are also accessible by the

View Tab. See http://tinyurl.com/Iz5pwag for even more information:

Normal: Default view. Dotted grey lines identify page breaks.

Page Layout: Displays exactly what would print on each page, including headers and footers,
images, etc.

Page Break Preview: The dashed blue line shows page breaks and identifies the page’s
number. Very useful for “wide” reports. Identify “orphan” columns or rows
disconnected from other pages.

To Create a Custom view, View > see http://tinyurl.com/m9ltxm8

Print a basic report
(Note: click on ¥ arrows to see more options)File > Print > click the

Bxcel Create Reports - Excel

Print button or <Cftrl p> - this brings up the Print dialog box,
home to many important options.

Print
Copies: click on up or down arrows to change the number of copies e
fo print. ot
Printer select available printer to physically print report, or choose Srinter
PDFCreator to save it as a .pdf file. You may have other R0 o) i
choices outside the Library. R —
Print Active Sheets this is one way to identify which data is to be Settings

printed.
Pages when specifying which pages to print, good for testing
Print One Sided or change to duplex
Collated or Uncollated

L_—l Print Active Sheets .
Only print the active sheets
S| to =

Pages:
Print One Sided

E Only print on one side of th..
Collated

EE -

123 123 123
Portrait Orientation or Landscape. See which one fits the number of ER
columns best. s .
Letter or other physical paper size. The Copy Center printers also 0 N;,,Zwma,gi_m
print 8 2" x 14" and 11" x 17". B&W for 10 cents, color for 25 e

Clun  Print sheets at their actual size
Page Setup

cents.

Normal Margins or Narrow or Custom. Some companies have
formatting standards.

No Scaling Very powerful tool for fitting big reports on the least amount of paper. The preview
on the right side will help you “see” if it is too small. Try Fit All Columns on One Page.
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